Version 26.3¶
2026年 10月 7日 巨大ファイル用の高速ビュー モードを追加しました。高速ビュー モードでは、ファイル全体をメモリに読み込まずに、巨大ファイルを書き換え禁止でほぼ瞬時に開きます。EmEditor はバックグラウンドで各行の位置を調べ、表示される行のみを読み込みます。ファイルを開き始めた直後から、EmEditor が各行の位置を調べている間でも、文書の末尾にジャンプできます。行番号は、各行の位置を調べ終わるまで表示されません。[高速ビュー モードを有効にする最小ファイル サイズ] (既定は 4,096 MB) より大きなファイルは自動的に高速ビュー モードで開かれ、ファイルが高速ビュー モードで開かれると通知が表示されます。通常モードと高速ビュー モードを切り替えるには、[編集] メニューの [高速ビュー] を選択します。 [PF] 高速ビュー モードでは、次の操作ができます。 スクロール、選択 (矩形選択を含む)、コピー ([引用付きコピー] を含む)、[ジャンプ]、[タグ ジャンプ]。 [PF] 検索 (正規表現、[数値範囲] と [あいまい一致] オプション、一致数のカウントを含む)。 [PF] 別のエンコード (バイナリ表示を含む) での再読み込みと、[名前を付けて保存] による別のエンコードや改行コードでの保存。 [PF] 文書の[比較] (通常モードの文書との比較を含む)。 [PF] 外部ツールの実行。 [PF] [検索] ダイアログ ボックスによる抽出、[連続検索] ダイアログ ボックスによる複数検索、[フィルター] ツール バーによるフィルターと抽出。 [P] CSV モード、[巨大ファイル コントローラー]、マクロ、プラグイン、[AI] メニューの使用。 [P] 高速ビュー モードでは、ブックマークの数は 1 文書あたり 100,000 個まで、垂直スクロール バー上の検索文字列のマーカーの数は 100,000 個までに制限され、[インクリメンタル サーチ] オプションは無効になります。 [PF] 現在、高速ビュー モードでは次の機能はサポートされていません。 [ミニマップ] [Markdown デザイン ビュー] [巨大ファイル コントローラー] の [開くフィルター] [ファイル] メニューの [検証]、[印刷]、[印刷プレビュー] 複数選択 [自動コピー] [ブックマークを反転] [構文チェッカー]、[アウトライン バー]、[アウトライン ガイド] [CSV] メニューの [セル選択モード]、[一時的に引用符を非表示]、[列の非表示]/[列の再表示]、[列幅をリセット]、[左揃え]/[中央揃え]/[右揃え] その他、文書を変更するコマンド 高速ビュー モードでは、[Null文字を含むファイルで警告] と [変換できない不正な文字で警告] オプションは、通常モードのようにファイル全体ではなく、ファイルの先頭部分のみを調べます。詳細は、[設定のプロパティ] の [ファイル] ページを参照してください。 [PF] 高速ビュー モードでは、ファイルが物理メモリよりはるかに大きい場合でも、巨大ファイルを開く操作と、検索、フィルター、抽出が以前のバージョンより高速になりました。下のテスト結果を参照してください。 v26.2 v26.3 比較 開く 30.2 秒 6.61 秒 4.57 倍に高速化 「abcde」を検索 (一致数のカウント) 37.0 秒 7.64 秒 4.84 倍に高速化 「abcde」でフィルター 69.6 秒 7.53 秒 9.24 倍に高速化 [検索] ダイアログ ボックスで「abcde」を抽出 103 秒 9.70 秒 10.6 倍に高速化 「[a-c]{5}」を検索 (正規表現、一致数のカウント) 198 秒 124 秒 1.60 倍に高速化 ASCII ランダム データのファイル (UTF-8、48.4 GB、10 億行)、既定のオプション、Windows 11、Ryzen 9 7950X。 物理メモリは 96 GB、 v26.3: 高速ビュー モードで開いた場合。 [カスタマイズ] ダイアログ ボックスの [高度] ページに、[高速ビュー モードを有効にする最小ファイル サイズ] テキスト ボックスを追加しました。 [PF] [巨大ファイル コントローラー] に、[高速ビュー モード] チェック ボックスを追加しました。 [P] Document オブジェクトに、FastView プロパティを追加しました。 Document オブジェクトに、Text プロパティと TextLength プロパティを追加しました。 WebBar オブジェクトに、scrollBy メソッド、scrollTo メソッド、scrollX プロパティ、scrollY プロパティを追加しました。 Document オブジェクトと Selection オブジェクトの、文書を変更しないプロパティとメソッドを、高速ビュー モードで使用できるようになりました。文書を変更するプロパティとメソッドは、高速ビュー モードでは失敗します。 EE_INFO メッセージに、EI_GET_FAST_VIEW パラメーターを追加しました。 EEID_FAST_VIEW コマンド ID を追加しました。 文書を読み取るメッセージやカーソルを移動するメッセージを、高速ビュー モードで使用できるようになりました。文書を変更するメッセージは、高速ビュー モードでは失敗します。 エクスプローラ: [カスタマイズ] ダイアログ ボックスの [ウィンドウ] ページで指定したダイアログ ボックスのフォント サイズを使用するようになりました。 チャットごとの AI 設定を追加しました。チャットごとの設定はそのチャットにのみ適用され、変更しても全体の設定には影響しません。 チャット入力ボックスに、AI モデルとツールの表示を追加しました。チャットで使用中の AI モデルと選択したツールを表示します。モデル名をクリックすると、[設定] ダイアログ ボックスが開きます。 外部サービスに接続するための MCP コネクタを追加しました。現在は HTTP サーバーのみサポートしています (STDIO と SSE の接続はサポートしていません)。 [設定] ダイアログ ボックスに [MCP コネクタ] ページを追加しました。MCP サーバーの構成 JSON を使用して、新しいコネクタを追加できます。 [EmEditor ヘルプ ページ] コネクタを追加しました。AI はこのコネクタを使用して最新の EmEditor ヘルプ ページにアクセスできるため、Web 検索ツールよりも的確な回答が得られます。 [P] EmEditor Professional のみ [PF] EmEditor Professional と EmEditor Free一般の新機能¶
テスト結果¶
bcdedit /set {current} truncatememory 17179869184 で 16 GB RAM の環境をシミュレート。新しい設定¶
マクロの新機能 [P]¶
プラグインの新機能 [P]¶
注¶