高速ビュー モードで巨大ファイルを開いて編集する¶
高速ビュー モードでは、巨大ファイルをメモリに読み込まずに、ほぼ瞬時に開きます。EmEditor はバックグラウンドで行の位置を調べ、画面に表示されている行のみを読み込みます。編集内容はファイルとは別に保持され、保存するまでファイルは変更されません。 [高速ビュー モードを有効にする最小ファイル サイズ] (既定は 4,096 MB) より大きなファイルを開きます。この設定は、[カスタマイズ] ダイアログ ボックスの [高速ビュー] ページで変更できます。ファイルは自動的に高速ビュー モードで開かれ、通知が表示されます。ファイルを自動的に高速ビュー モードで開かないようにするには、サイズを 0 に設定します。 現在の文書を通常モードと高速ビュー モードで切り替えるには、[編集] メニューの [高速ビュー] コマンドを選択するか、ステータス バーの [FAST] をダブルクリックします。[巨大ファイル コントローラー] の [高速ビュー モード] チェック ボックスを選択して [適用] をクリックすることもできます。 差分ファイル (下記参照) があるファイルは、最小ファイル サイズより小さくても、常に高速ビュー モードで開かれます。 文書が高速ビュー モードの間は、ステータス バーに [FAST] が表示され、文書タブに稲妻のアイコンが表示されます。無題の文書は高速ビュー モードに切り替えることができません。 ファイルを開き始めた直後から、EmEditor が行の位置を調べている間でも、ファイルの末尾にジャンプできます。行番号は、すべての行の位置を調べ終わると表示されます。 スクロール (スムーズ スクロールを含む)、選択 (矩形選択と複数選択を含む)、コピー、ジャンプ、フィルター、部分編集。部分編集中は、編集と文書全体を変更するコマンドは、部分編集の行のみに影響します。 強調文字列、コメント、引用符で囲まれた文字列、マーカー、ブックマーク、ルーラー、記号の表示。 検索、カウント、置換、抽出 (正規表現と複数行にわたる文字列を含む)。[検索] ダイアログ ボックス、[検索] ツール バー、[高度] ダイアログ ボックスの多くのオプションを利用できます。 [PF] [セル選択モード] を含む CSV モードの使用。 [P] 文書を変更するほとんどのコマンドを使用した編集。[元に戻す]/[やり直し]、[挿入]、[変換]、[並べ替え]、[CSV] メニュー、マクロ、プラグインを含みます。高速ビュー モードでサポートされていない機能については、制限事項を参照してください。 ファイルが書き換え禁止の場合、バイナリ (16 進表示) で開いている場合、巨大ファイル コントローラーでファイルの一部を開いている場合、フィルターが適用されている間、または文書の比較中は、文書を編集できません。編集を停止するには、[書き換え禁止] をオンにします。多くの行を変更するコマンドは、複数のスレッドで実行されます。EmEditor は編集内容をメモリに保持するため、利用できるメモリが不足するとメッセージが表示されます。その場合は、編集内容を保存するか、通常モードに切り替えてください。 巨大ファイルの保存には時間がかかることがあるため、高速ビュー モードの文書を保存するときに、保存方法を確認するメッセージが表示されます。 [保存してマージ] は、変更内容をファイルに書き込みます。 [変更内容だけを保存] は、変更内容を差分ファイルに保存し、元のファイルは変更しません。次回ファイルを開くときに、変更内容が自動的に適用されます。後で [保存してマージ] を選択して、変更内容をファイルにマージすることもできます。 [今後このメッセージを表示しない] を選択すると、EmEditor は選択内容を記憶します。後で変更するには、[カスタマイズ] ダイアログ ボックスの [高速ビュー] ページの [高速ビュー モードで巨大なファイルを保存する時に確認する] と [高速ビュー モードで巨大なファイルを保存する時に変更内容だけを差分ファイルに保存する] オプションを使用します。[名前を付けて保存] は、常に変更内容を含めてファイル全体を書き込みます。 すべてのコマンドメニューの [ファイル] - [差分] サブメニューにある、次のコマンドも使用できます。 差分ファイルには、ファイルの編集内容と行の位置が保存されます。これにより、次回は行の位置をもう一度調べずに、巨大ファイルを即座に開くことができます。差分ファイルは、元のファイルの隣ではなく、EmEditor のローカル アプリケーション データ フォルダー内の FastView フォルダーに保存されます。 [巨大ファイルの行の位置を保存して、次回すぐに開けるようにする] オプションがオン (既定) の場合、最小ファイル サイズより大きなファイルの行の位置は、調べ終わった後と、ファイルを保存するときに保存されます。 EmEditor の外部でファイルの名前を変更したり移動したりしても、差分ファイルはそのファイルに適用されます。 ファイルが差分ファイルの保存後に変更された場合、ファイルが異なるエンコードで開かれている場合、または引用符で囲まれたセル内の改行を許可する CSV の設定が異なる場合は、差分ファイルを適用できません。 行の位置のみを含む差分ファイルは、ファイルのサイズが変更された場合、またはファイルが 30 日より長く存在しない場合に、自動的に削除されます。また、新しい 100 個のみが保持されます。編集内容を含む差分ファイルは、自動的に削除されることはありません。 差分ファイルを確認または削除するには、[カスタマイズ] ダイアログ ボックスの [高速ビュー] ページを使用します。 高速ビュー モードの文書は、ワークスペースに含まれます。ワークスペースを保存するときに、変更されていない各文書の行の位置も保存されるため、ワークスペースは行の位置をもう一度調べずに開きます。保存されていない編集内容はワークスペースに保存され、文書は変更された状態で復元されます。 各文書のブックマークは 100,000 個まで、垂直スクロール バーに表示される検索文字列のマーカーは 100,000 個までです。 [Null文字を含むファイルで警告] と [変換できない不正な文字で警告] オプションは、ファイルの先頭部分のみを調べます。詳細は、[設定のプロパティ] ダイアログ ボックスの [ファイル] ページを参照してください。 高速ビュー モードでは、次の機能は利用できません。これらの機能を使用するには、通常モードに切り替えてください。 [編集] メニュー: [対応するタグへ]、[選択範囲を対応するタグへ]、[Markdown/HTML] サブメニュー ([Markdown デザイン ビュー] を含む)、[スペル チェック]、[構文チェック]。 [挿入] メニュー: [オートフィル/オートリピート]。 [変換] メニュー: [改行コードを削除]、[行の結合]、および [選択範囲のエンコード/デコード] の Base64、Markdown、HTML の変換。 [ブックマーク] メニュー: [この文書のブックマークを反転]、[この文書のブックマークされた行を選択]。 [検索] メニュー: [次の警告すべき/Unicode文字を検索] と [Unicode文字の強調を解除]。 [検索] ダイアログ ボックスと [検索] ツール バー: [インクリメンタル サーチ]。[グループのすべての文書から検索] を使用する場合、[すべて選択] と [抽出] は、アクティブな文書以外の高速ビュー モードの文書をスキップします ([次を検索]、[カウント]、[ブックマーク] は、すべての文書を検索します)。 [フィルター] ツール バー: [インクリメンタル サーチ] と [複数行の変更をブロック]。 [表示] メニュー: [折り返し] コマンド、[構文チェッカー]、[アウトライン バー]、[アウトライン ガイド]、[タブ/インデント] オプション、[タグ リンク]、[保存行のマーカーをクリア]、[ミニマップ]。 [CSV] メニュー: [固定幅列に変換]、[フラッシュ フィル]、[行/列の入れ替え]、[ピボット テーブル]、[ピボット解除]、[セパレーター] サブメニュー、および [CSV コンバーター] バーの [変換]、[自動的にセパレーターを追加]、[列の幅よりも長い文字列は切り詰める]。 マクロ: Document オブジェクトの AutoFill、ConvertCsv、PivotTable、Unpivot メソッドは失敗します。 [P] [カスタマイズ] ダイアログ ボックスの [高速ビュー] ページ Document オブジェクトの FastView プロパティ高速ビュー モードでファイルを開くには¶
高速ビュー モードでできること¶
編集内容を保存するには¶
差分ファイル¶
制限事項¶
関連項目¶