以快速查看模式打开和编辑超大文件¶
快速查看模式可以几乎瞬间打开超大文件,而无需将其载入内存。EmEditor 会在后台查找各行,并且只读取屏幕上显示的行。你的编辑内容会被单独保留,在你保存之前,文件不会发生变化。 打开一个大于 启用快速查看模式的最小文件大小(默认 4,096 MB)的文件,该大小在 自定义 对话框的 快速查看 页面 上设置。文件会自动以快速查看模式打开,并显示通知。要始终不自动以快速查看模式打开文件,请将该大小设为 0。 要在普通模式与快速查看模式之间切换当前文档,请选择 编辑 菜单上的 快速查看 命令,或双击状态栏上的 FAST。你也可以在 大文件控制器 中勾选 快速查看模式 复选框,然后点击 应用。 有差异文件(见下文)的文件总是以快速查看模式打开,即使它小于最小文件大小。 当文档处于快速查看模式时,状态栏上会显示 FAST,文档标签上会显示闪电图标。未命名的文档无法切换到快速查看模式。 文件一开始打开,即使 EmEditor 仍在查找各行,你也可以立即跳转到文件末尾。找到所有行后会显示行号。 滚动(包括平滑滚动)、选择文本(包括垂直选择和多重选择)、复制、跳转,以及使用 筛选 和 仅编辑选定区域。在仅编辑选定区域时,编辑以及更改整个文档的命令只影响选定区域内的行。 显示高亮字符串、注释、引号字符串、标记、书签、标尺和 标记。 查找、统计、替换和提取文本,包括使用正则表达式以及跨行的文本。查找 对话框、查找 工具栏和 高级 对话框 的许多选项都可以使用。[PF] 使用 CSV 模式,包括 单元格选择模式。[P] 你可以进行编辑,并使用大多数会更改文档的命令,包括 撤消/重做、插入、转换、排序 和 CSV 菜单,以及宏和插件。快速查看模式不支持的功能请参见限制。 如果文件是只读的、以二进制(十六进制查看)打开,或使用 大文件控制器 部分打开,或者正在应用筛选,或者正在比较文档,则无法编辑文档。要停止编辑,请打开 只读。更改多行的命令会在多个线程上运行。EmEditor 会将你的编辑内容保留在内存中,如果编辑内容需要的内存超过了可用内存,会显示一条消息。出现这种情况时,请保存编辑内容或切换到普通模式。 保存超大文件可能需要很长时间,因此当你在快速查看模式下 保存 文档时,EmEditor 会询问你要如何保存: 保存并立即合并 会将你的更改写入文件。 仅保存我的更改 会将你的更改保存到差异文件,并保持原文件不变。下次打开该文件时,这些更改会被自动应用。你之后可以选择 保存并立即合并,将它们合并到文件中。 如果选择 不再显示此消息,EmEditor 会记住你的选择。要在之后更改它,请使用 自定义 对话框的 快速查看 页面 上的 在快速查看模式下保存超大文件时提示 和 在快速查看模式下保存超大文件时,仅将更改保存到差异文件 选项。另存为 总是写入包括你的更改在内的整个文件。 你也可以使用 所有命令 菜单中 文件 > 差异 子菜单上的以下命令: 差异文件会保存你对文件的编辑内容以及文件中行的位置,使超大文件下次打开时可以立即打开,而无需再次查找各行。差异文件保存在 EmEditor 本地应用程序数据文件夹中的 FastView 文件夹中,而不是保存在原文件旁边。 当 保存超大文件中行的位置,以便下次立即打开 选项打开时(默认),大于最小文件大小的文件中行的位置会在找到后保存,并在保存文件时再次保存。 如果你在 EmEditor 之外重命名或移动了文件,其差异文件仍然适用于该文件。 如果文件在保存差异文件之后发生了变化、文件以不同的编码打开,或者允许引号内单元格换行的 CSV 设置不同,则无法应用差异文件。 只包含行的位置的差异文件,会在其文件的大小发生变化或文件丢失超过 30 天时被自动删除。这类差异文件只保留最新的 100 个。包含编辑内容的差异文件永远不会被自动删除。 要查看和删除差异文件,请使用 自定义 对话框的 快速查看 页面。 快速查看模式下的文档会包含在工作区中。保存工作区时,每个未修改的文档中行的位置也会被保存,因此打开工作区时无需再次查找各行。未保存的编辑内容会保存在工作区中,文档会以已修改的状态还原。 每个文档最多可以有 100,000 个书签,垂直滚动条上最多显示 100,000 个查找字符串标记。 如果发现空字符时进行提示 和 如果发现无效字符时进行提示 选项只检查文件的开头部分。详细信息请参见 配置属性 的 文件 页面。 以下功能在快速查看模式下不可用。要使用这些功能,请切换到普通模式。 编辑 菜单:查找匹配标签、扩展选区至匹配的标签、Markdown/HTML 子菜单(包括 Markdown 设计视图)、拼写检查 和 语法检查。 插入 菜单:自动填充/自动重复。 搜索 菜单:查找下一个/上一个警告/Unicode 字符 和 取消 Unicode 高亮。 查找 对话框和 查找 工具栏:渐进式搜索。使用 搜索群组中所有打开的文档 时,全部选择 和 提取 会跳过活动文档以外的快速查看文档。(查找下一个、统计 和 设为书签 会搜索所有这些文档。) 筛选 工具栏:渐进式搜索 和 阻止多行更改。 查看 菜单:换行 命令、语法检查器、大纲栏 和 大纲导航、制表符/缩进 选项、标签链接、清除保存过的行的标记 以及 迷你地图。 CSV 菜单:转换为固定列宽、快速填充、转置、数据透视表、逆透视、分隔符 子菜单,以及 CSV 转换器 栏上的 立即转换、自动添加分隔符 和 截断字符串如果字符串长于列宽。 宏:Document 对象的 AutoFill、ConvertCsv、PivotTable 和 Unpivot 方法会失败。[P] 自定义 对话框的 快速查看 页面 Document 对象的 FastView 属性以快速查看模式打开文件¶
在快速查看模式下可以做的事¶
保存编辑内容¶
差异文件¶
限制¶
另请参阅¶