在快速檢視模式中開啟和編輯巨型檔案¶
快速檢視模式幾乎能瞬間開啟巨型檔案,而無需將檔案載入記憶體。EmEditor 會在背景中尋找各行,並且只讀取畫面上顯示的行。您的編輯內容會另外保存,在您儲存之前,檔案不會變更。 開啟大於 啟用快速檢視模式所需的最小檔案大小(預設為 4,096 MB)的檔案,此大小可在 自訂 對話方塊的 快速檢視 頁面 上設定。檔案會自動以快速檢視模式開啟,並顯示通知。若要永不自動以快速檢視模式開啟檔案,請將大小設定為 0。 若要在一般模式與快速檢視模式之間切換目前的文檔,請在 編輯 功能表中選擇 快速檢視 命令,或在狀態列上雙擊 FAST。您也可以在 大檔案控制器 中勾選 快速檢視模式 核取方塊,然後按一下 套用。 具有差異檔(見下文)的檔案一律以快速檢視模式開啟,即使該檔案小於最小檔案大小也是如此。 文檔處於快速檢視模式時,狀態列上會顯示 FAST,並且文檔索引標籤上會顯示閃電圖示。未命名的文檔無法切換到快速檢視模式。 檔案一開始開啟,即使 EmEditor 仍在尋找各行,您也可以立即跳轉到檔案末尾。找到所有行之後才會顯示行號。 捲動(包括平滑捲動)、選取文字(包括垂直選取和多重選取)、複製、跳轉,以及使用 篩選 和 僅編輯選定區域。在僅編輯選定區域時,編輯以及會變更整個文檔的命令只會影響選定區域內的行。 顯示亮顯字串、註釋、引號字串、標記、書籤、尺規以及 段落標記。 尋找、計數、取代和擷取文字,包括使用規則運算式以及跨行的文字。尋找 對話方塊、搜尋 工具列以及 進階 對話方塊 中的許多選項都可以使用。[PF] 使用 CSV 模式,包括 儲存格選擇模式。[P] 您可以編輯,並使用大多數會變更文檔的命令,包括 復原/重做、插入、轉換、排序 和 CSV 功能表,以及巨集和外掛程式。有關快速檢視模式不支援的功能,請參見限制。 如果檔案為唯讀、以二進位(十六進位檢視)開啟、使用 大檔案控制器 部分開啟、正在套用篩選,或正在比較文檔,則無法編輯文檔。若要停止編輯,請開啟 唯讀。會變更許多行的命令會以多執行緒執行。EmEditor 會將您的編輯內容保存在記憶體中,如果編輯內容需要的記憶體超過可用量,則會顯示訊息。發生這種情況時,請儲存編輯內容,或切換至一般模式。 儲存巨型檔案可能需要很長的時間,因此當您在快速檢視模式中 儲存 文檔時,EmEditor 會詢問您要如何儲存: 儲存並立即合併 會將變更寫入檔案。 僅儲存我的變更 會將變更儲存至差異檔,並保持原始檔案不變。下次開啟檔案時,會自動套用這些變更。您之後可以選擇 儲存並立即合併,將變更合併至檔案。 如果您選擇 不要再顯示此訊息,EmEditor 會記住您的選擇。若要在之後變更,請使用 自訂 對話方塊中 快速檢視 頁面 上的 在快速檢視模式中儲存巨型檔案時提示 和 在快速檢視模式中儲存巨型檔案時,僅將變更儲存至差異檔 選項。另存新檔 一律會寫入包括變更在內的整個檔案。 您也可以使用 全部命令 功能表中 檔案 > 差異 子功能表上的以下命令: 差異檔會儲存您對檔案的編輯內容以及檔案中各行的位置,讓巨型檔案下次能立即開啟,而無需再次尋找各行。差異檔儲存在 EmEditor 本機應用程式資料資料夾的 FastView 資料夾中,而不是原始檔案旁邊。 當 儲存巨型檔案中行的位置,讓下次能立即開啟 選項開啟時(預設),大於最小檔案大小的檔案在找到行的位置後會儲存其位置,並在儲存檔案時再次儲存。 如果您在 EmEditor 以外重新命名或移動檔案,其差異檔仍然適用於該檔案。 如果檔案在儲存差異檔之後已變更、以不同的編碼開啟,或允許引號儲存格內換行的 CSV 設定不同,則無法套用差異檔。 僅包含行位置的差異檔,會在其檔案大小變更或檔案遺失超過 30 天時自動刪除。這類差異檔只會保留最新的 100 個。包含編輯內容的差異檔永遠不會被自動刪除。 若要檢視和刪除差異檔,請使用 自訂 對話方塊的 快速檢視 頁面。 快速檢視模式中的文檔會包含在工作區中。儲存工作區時,也會儲存每個未修改文檔的行位置,因此開啟工作區時無需再次尋找各行。未儲存的編輯內容會儲存在工作區中,並且文檔會以已修改的狀態還原。 每個文檔最多可有 100,000 個書籤,垂直捲軸最多顯示 100,000 個尋找字串標記。 發現空值字元時進行提示 和 發現無效字元時進行提示 選項只檢查檔案的開頭部分。詳細資訊請參見 組態屬性 的 檔案 頁面。 以下功能在快速檢視模式中無法使用。若要使用這些功能,請切換至一般模式。 編輯 功能表: 搜尋符合的標籤、延伸選取到配對的標籤、Markdown/HTML 子功能表(包括 Markdown 設計檢視)、拼字檢查 和 語法檢查。 插入 功能表: 自動填滿/自動重複。 搜尋 功能表: 尋找下一個/上一個警告/Unicode 字元 和 取消 Unicode 醒目提示。 尋找 對話方塊和 搜尋 工具列: 漸進式搜尋。勾選 搜尋群組中所有文件 時,全部選取 和 擷取 會略過使用中文檔以外的快速檢視文檔。(尋找下一個、計數 和 設為書籤 會搜尋所有文檔。) 篩選 工具列: 漸進式搜尋 和 阻止對多行進行修改。 檢視 功能表: 換行 命令、語法檢查器、大綱顯示條 和 大綱導引、Tab/縮排 選項、標籤連結、清除儲存過的行的標記,以及 迷你地圖。 CSV 功能表: 固定欄寬、快速填入、轉置、樞紐分析表、取消樞紐、分隔符號 子功能表,以及 CSV 轉換器 上的 轉換、自動添加分隔符號 和 截斷不符合欄寬的字串。 巨集: Document 對象的 AutoFill、ConvertCsv、PivotTable 和 Unpivot 方法會失敗。[P] 自訂 對話方塊的 快速檢視 頁面 Document 對象的 FastView 屬性以快速檢視模式開啟檔案¶
在快速檢視模式中可以執行的操作¶
儲存編輯內容¶
差異檔¶
限制¶
請同樣參考¶